叉烧店并不卖叉烧

npm、Webpack和Vue.js注意事项

npm TTT 30℃ 0评论

对于webpack编译出来的js文件,如果在浏览器无法,一片空白

可能是各种依赖的版本引起的,可以在package.json文件中看各个依赖的版本并且修改

npm install // 此命令可以根据package.json文件中的依赖内容下载对应的依赖(库)
npm install [--save-dev|--save] 依赖名@版本号 // 根据此命令下载依赖

使用Webpack编译出来的Vue.js项目不能再IE中运行

可能是没有将Vue.js中的ES6语法编译成ES5语法,所以需要再webpack.config.js文件中增加babel插件

npm install --save-dev babel-loader@7 babel-core babel-preset-env // 安装
// webpack.config.js
const VueLoaderPlugin = require("vue-loader/lib/plugin");

module.exports = {
 ……
    module: {
        rules: [
……
            {
                test: /(\.jsx|\.js)$/,
                use: {
                    loader: "babel-loader",
                    options: {
                        presets: [
                            "env"
                        ]
                    }
                },
                exclude: /node_modules/
            }
        ]
    },
……
}

转载请注明:叉烧店 » npm、Webpack和Vue.js注意事项

喜欢 (0)
发表我的评论
取消评论

CAPTCHA Image
Reload Image
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址